Home - Waterfall Grid T-Grid Console Builders Recent Builds Buildslaves Changesources - JSON API - About

Change #8043

Category None
Changed by Josh Stompro <stomproohnoyoudont@stompro.org>
Changed at Mon 20 Sep 2021 10:05:53
Repository git://git.evergreen-ils.org/Evergreen.git
Project Evergreen
Branch master
Revision a9b3b6dedb45dd7952e7fd798bba668eecf296ad

Comments

LP#1821804 - Cloned patron address set to pending
When cloning a patron record, the address gets set to pending and cannot
be fixed until the new patron record is saved.

The address creation steps for cloned records are a little different if
the library setting "Patron Registration: Cloned patrons get address copy" is
set, so test with that enabled and disabled.  In our system we have that setting
enabled.

The issue is that the values come in as a string like 't' or 'f' and need to be converted
to a boolean value.  That is done in the normal address loading code, but wasn't in
the cloning code.

I also added in a fix for the city limits flag not getting cloned which seems
like an related issue.  This seems like it was just cosmetic, the city limits
does get set when the record is saved, based on the parent records address.

Testing Plan:

Before change:

1. Enable "Cloned patrons get address copy" setting.
2. Open up a patron record that has a valid non pending address with city limits checked.
3. Save and Clone
4. Notice that the address in the new cloned record says pending.
5. Notice that the city limits checkbox isn't checked.

After change applied:

1. Enable "Cloned patrons get address copy" setting.
2. Open up a patron record that has a valid non pending address with city limits checked.
3. Save and Clone
4. Notice that the address in the new cloned record doesn't say pending.
5. Notice that the city limits checkbox is checked.

Signed-off-by: Josh Stompro <stompro@stompro.org>
Signed-off-by: Ruth Frasur <rfrasur@library.in.gov>
Signed-off-by: Bill Erickson <berickxx@gmail.com>

Changed files